Freidenker01

Maybe this isn't a bug necessarily...

I recognized that some versions ago spine used to add a "-1" to the textures filename when exporting.
I assume this comes along with the functionality of the scale output. (even if I just use one scalefactor of 1.0)

So I started to delete the old version of the texture when I've updated(and exported) a spine-file.

And here's my problem. I updated another old spine-file with the newest version of spine (1.8.09) and it didn`t add the "-1".
But when I update a spine-file wich allready had that "filename-1.png" texture it still did create that kind of texturename.
And this is actually a littlebit confusing.

So....what am I doing wrong :S or where can I set wether the "-1" should be added or not? Cause actually I didn`t find any setting.
Avatar utente
Freidenker01
  • Messaggi: 57

Pharan

I just tried it now (exporting a recent project to a folder with a previous export).
I don't think it detects whether it used to use "-1" or not. It just doesn't use it anymore.

Are you sure you were actually exporting a new atlas?
Avatar utente
Pharan
  • Messaggi: 5366

Nate

It no longer adds "-1" to the first image. Scaled atlases output to subdirectories so the atlas image file names don't need to be unique. Delete your old atlas images and export again and it should work fine.
Avatar utente
Nate

Nate
  • Messaggi: 12210

Freidenker01

Great! Thank you for your superquick respond :yes:
Avatar utente
Freidenker01
  • Messaggi: 57


Torna a Bugs