Slacky

Every time I set up my draw order in SETUP mode it changes when I go in to ANIMATION mode.

Can you lock the draw mode so it doesn't change.


Very new to the program and have searched forum etc.

Everything else is really good. This is driving me mad.

Unfortunately only have the trial, so will have to start over to try out any solutions before I buy.

Cheers.
Slacky
  • Messaggi: 3

Søren

Are you sure you haven't set a key for draw order? Draw order definitely shouldn't be changing when you set it in Setup mode. I've just checked here and don't have the problem.
Scroll to the bottom of the dopesheet and see if there are any keys for draw order.
Avatar utente
Søren

Shiu
  • Messaggi: 2453

rationalise

I am also seeing this issue - I don't have any keys on draw order but when I toggle to animation mode the draw order changes I made are lost
Avatar utente
rationalise
  • Messaggi: 5

Søren

We'll dig into it ASAP and see if we can reproduce.
Avatar utente
Søren

Shiu
  • Messaggi: 2453

Pharan

Tried it with Speedy and it does happen.

Draw Order changes in setup mode aren't persisting.
(1) Move a slot (I used hair1) to the bottom of the draw order list.
(2) Switch to animate mode. (changes are lost)
(3) Switch back to Setup Mode. (the draw order is back to the way it was before step 1)
Avatar utente
Pharan
  • Messaggi: 5366

Søren

cheers Pharan, reproduced. We'll see if we can get a fix out for it while we sort the problems with framerate we're currently having.
Avatar utente
Søren

Shiu
  • Messaggi: 2453

atombrot

Is there currently a work around to this problem, so I still could animate my skeletons? I can only downgrade to version 1.8 (i might still have the installer from after kickstarter, but there is nothing left from 1.7). If there isn't a work around, how long do you think we have to wait for the fix? I want to continue my poor ugly programmer art assets ;)
atombrot
  • Messaggi: 2

Søren

Afraid you'll have to roll back further than 1.8. I think we can have a fix for it within the next 24 hours.
Avatar utente
Søren

Shiu
  • Messaggi: 2453

Nate

Working on the problem. For now you can rollback to 1.7.12. If you don't see 1.7.12 in your list of updates on the Settings dialog, please download and reinstall Spine then it should appear.
Avatar utente
Nate

Nate
  • Messaggi: 12210

Nate

Uploading 1.8.06 now with draw order fixed. I'm a bit sick today and the changes to fix this were quite large, so if something doesn't work just revert to an older version. Always backup your projects, or worst case you can get your projects from the backups Spine makes here:
Windows: <user home folder>\Spine\backups\
Mac: <user home folder>/Library/Application Support/Spine/backups/
Linux: <user home folder>/.spine/backups/
Avatar utente
Nate

Nate
  • Messaggi: 12210

atombrot

Hey. I tried it out with the latest version and it works now correctly for me. Thanks very much. My cyborg appreciates it to be able to walk ;)
=> http://imgur.com/a/6KXBQ
atombrot
  • Messaggi: 2

Slacky

Cheers guys!
Slacky
  • Messaggi: 3


Torna a Bugs