mingyunzhimen

currently i make a game with unity spine-runtime.
We make a Skeletal animation .In the spine view ,it is normal,but after import into unity there is something wrong happened.
In the unity view ,It produced a dislocation between the various parts of the body.
you can find it form the attach image.
Who can tell me how to solve this problem?
Thanks. :S
spine.jpg
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
mingyunzhimen
  • Messaggi: 3

Pharan

Are you using meshes?
Did you make sure to uncheck "Strip Whitespace X" and "Strip Whitespace Y" in the Create Atlas/Texture Packer Settings?
Avatar utente
Pharan
  • Messaggi: 5366

mingyunzhimen

Pharan ha scritto:Are you using meshes?
Did you make sure to uncheck "Strip Whitespace X" and "Strip Whitespace Y" in the Create Atlas/Texture Packer Settings?
they are both checked! So i should uncheck them?thanks.
mingyunzhimen
  • Messaggi: 3

Pharan

If you are using meshes, you should uncheck them. :)
Avatar utente
Pharan
  • Messaggi: 5366

mingyunzhimen

Pharan ha scritto:If you are using meshes, you should uncheck them. :)
thank you very much,sir. :handshake:
May i ask another question about import spine resource?
I found that the Skeleton animation is too big in the unity scene(the size expand about 100 times) !
Do you know how to fix this? Am i forgot some steps with the Export Process?
thanks!
mingyunzhimen
  • Messaggi: 3

Pharan

In Unity, find the SkeletonDataAsset file in Unity in your Project view. (the icon is the orange Spine icon)
Change the Scale. 0.01 should be a good number.
If it's still too big, make the number smaller: try 0.001.

Make sure you let it reload if you don't see the changes. Try to reopen the Scene, or click Reload on the SkeletonAnimation component.
Avatar utente
Pharan
  • Messaggi: 5366


Torna a Unity