Martin2

It looks like both the Maximize and Fullscreen buttons does a similar thing in 4.0.61. They both place the editor in a sort of fullscreen mode like a game would. It doesn't work well with other applications, especially if the editor is not placed on the primary screen.
Can we get the normal "maximized window" functionality on the Maximize button?
Martin2
  • Messaggi: 6

Nate

What OS are you using?

Windows has special behavior when an app window is sized to the screen. For example, Windows may prevent the mouse from leaving the window. We can't stop that from happening. The "fullscreen" button sizes to the screen, so the special behavior occurs.

If you have a taskbar then "maximize" sizes Spine's window to the size of the screen minus the taskbar size. This doesn't trigger the special behavior because the window is smaller than the screen.

If your taskbar is set to auto hide or you have the window on a monitor with no taskbar, then "maximize" will make the window 1px smaller than the screen. This is the only way we can avoid the special behavior. You should never see the special behavior when you maximize.
Avatar utente
Nate

Nate
  • Messaggi: 12032

Martin2

I'm using Windows 10 with two monitors, and the taskbar setting "Show taskbar on all displays" is disabled.

And you're right, maximize works as expected on the monitor where the taskbar is. But if I maximize Spine on the other screen it will go into "special behaviour" mode. It's reproducible on both screens just by moving the taskbar between them.

However, I can learn to live with it now that I know what's causing it.
Martin2
  • Messaggi: 6

Nate

Thanks for the extra info, we'll take another look at that situation. What version of Spine are you using?
Avatar utente
Nate

Nate
  • Messaggi: 12032

Martin2

Spine version: 4.0.61
Martin2
  • Messaggi: 6


Torna a Bugs