Quinn

I am using the Mac version of Spine and after downloading the new launcher and waiting for it to install 1.8.09, Spine does not open. The loading dialog hangs at 99%, and ticks over to 100% after a long wait, but Spine itself does not open. I upgraded to Mavericks recently and had to install the Java runtime again, if that's significant, although my other Java-based software seems to run without any trouble.
Quinn
  • Messaggi: 15

Nate

Can you try again now? We just did a release which requires OS X users to download and reinstall Spine. Hopefully it will work. If not, can you post the contents of the file here?
<user home folder>/Library/Application Support/Spine/spine.log
Avatar utente
Nate

Nate
  • Messaggi: 12210

Quinn

I downloaded the launcher using the link from my original purchase email, but now the launcher doesn't open at all - I click it and nothing happens. I reinstalled the launcher twice to be sure, but I'm still unable to open it. Here's the contents of the log file, but note that this log file was last modified today when I opened the old launcher - it does not appear to have been modified when I attempted to open the updated launcher.

Spine Launcher 1.8.06-full
Mac OS X x86_64 10.9.2
Java 1.6.0_65 Apple Inc.
Java HotSpot(TM) 64-Bit Server VM
Downloading: update
Update complete.
Licensed to: xxx
Spine launcher update required, please reinstall.
Quinn
  • Messaggi: 15

Nate

Sorry you are still having trouble. :( If you delete the spine.log file, does it reappear when you run Spine? If you run the Console OS X app, do you see any useful information there after trying to run Spine?
Avatar utente
Nate

Nate
  • Messaggi: 12210

Quinn

No, the log file does not appear and nothing shows up at all in the Console when I try to run the app. It seems like literally nothing is happening when I double-click it.
Quinn
  • Messaggi: 15

Nate

Wow that is odd. Can you try running this command (copy and paste it into Terminal):
/Applications/Spine/Spine.app/Contents/MacOS/launcher/jre/bin/java -jar /Applications/Spine/Spine.app/Contents/MacOS/launcher/launcher-full.jar
Avatar utente
Nate

Nate
  • Messaggi: 12210

Quinn

I get this:

Error occurred during initialization of VM
java/lang/ClassNotFoundException: error in opening JAR file <Zip file open error> /Applications/Spine/Spine.app/Contents/MacOS/launcher/jre/lib/rt.jar

When I run it using sudo, the launcher opens, and asks for an activation code. I'm not sure what this is - I tried my order number from the original email, but that doesn't seem to do anything. I can't find a code anywhere in my email archives.
Quinn
  • Messaggi: 15

Nate

Very strange sudo worked, makes me think some permissions are wrong. I redid the permissions for the PKGs and reuploaded them. Maybe I could bother you to download and reinstall once again? Sorry, I'm sure you've done it a number of times already. :(

The activation code is provided on your download page, a link to which was emailed to you when you purchased. I will email it to you again right now so it is easy to find.
Avatar utente
Nate

Nate
  • Messaggi: 12210

Quinn

It still doesn't open. I'm able to use the sudo version of that terminal command to open and use Spine now, although it shows up as "Launcher" in Finder, with the Java logo instead of the Spine one, if that's significant. Running the command without sudo gives the same error as before.
Quinn
  • Messaggi: 15

Nate

I believe I've found the issue with bad permissions and I've uploaded new DMG files. If you download and reinstall one last time, it should work properly. :heart: Sorry again for the hassle! I tested on two different Macs without issue, I wish it would have failed for me.
Avatar utente
Nate

Nate
  • Messaggi: 12210

Quinn

It works! Thanks so much for your help.
Quinn
  • Messaggi: 15

Nate

Weee! :D
Avatar utente
Nate

Nate
  • Messaggi: 12210


Torna a Bugs