maranpis

Hello guys :)

So I have this animation where the glove switch to one image to another

here you can see the image switched

but when I copy the frames in the same animation

it doesn't copy the switching from the tree


I tried ctr+shift l to copy all the frames when it changes, but it doesn't copy the switch from the animation tree.

Why is that?

Thanks for your answers.
maranpis
  • Messaggi: 21

Nate

It's hard to tell what's going on, but your screenshots point to deform keys, not to slot attachment change keys. Deform is for moving vertices and start with Deform: . The slot attachment keys are for hiding/showing a slot's attachment and start with Attach: , like:
Avatar utente
Nate

Nate
  • Messaggi: 12040

maranpis

Nate ha scritto:It's hard to tell what's going on, but your screenshots point to deform keys, not to slot attachment change keys. Deform is for moving vertices and start with Deform: . The slot attachment keys are for hiding/showing a slot's attachment and start with Attach: , like:
Hello Nate, thanks for your answer, maybe I'm doing wrong the slot attachment change? What I'm doing is change the clip from the animation tree from one mesh to another with the autokey on.

I know that I also can use visibility on/off but with this method it's more difficult to select the images because all the images are on the same place, and it takes time to select the appropriate one. I have like 4 images for each glove, for example.

---

Nate ha scritto:It's hard to tell what's going on, but your screenshots point to deform keys, not to slot attachment change keys. Deform is for moving vertices and start with Deform: . The slot attachment keys are for hiding/showing a slot's attachment and start with Attach: , like:
Hello Nate, I actually did a test in a new file and I realized that maybe there is something wrong? In the new file when I turned the image in to a mesh and hide it the slot's attachment key appears, but in my actual file if I do the same only appears the deform key. Should I send you the file?

Thanks again.

---

Nate ha scritto:It's hard to tell what's going on, but your screenshots point to deform keys, not to slot attachment change keys. Deform is for moving vertices and start with Deform: . The slot attachment keys are for hiding/showing a slot's attachment and start with Attach: , like:
Hello Nate I have solved doing a new animation again and now it seems to work well still don't know what happened but at least has a solution.
maranpis
  • Messaggi: 21

Nate

maranpis ha scritto:In the new file when I turned the image in to a mesh and hide it the slot's attachment key appears, but in my actual file if I do the same only appears the deform key. Should I send you the file?
There is only one way to hide an attachment: by clearing the visibility dot for the attachment under the slot. This will never set a deform key. If you can show the steps you are taking that results in a deform key, then we could help further.

Likely you are clicking the key button next to the mesh, that will set a deform key. When hiding an attachment the attachment is not keyed, the slot is:
Keys - Spine User Guide: Slot attachment

So, click the attachment visibility dot to hide/show the attachment you want to hide/show. If you have auto key on, a key is set for you automatically. If not, click the key button next to the slot (not next to the attachment). Most people leave auto key enabled.
Avatar utente
Nate

Nate
  • Messaggi: 12040

maranpis

Nate ha scritto:
maranpis ha scritto:In the new file when I turned the image in to a mesh and hide it the slot's attachment key appears, but in my actual file if I do the same only appears the deform key. Should I send you the file?
There is only one way to hide an attachment: by clearing the visibility dot for the attachment under the slot. This will never set a deform key. If you can show the steps you are taking that results in a deform key, then we could help further.

Likely you are clicking the key button next to the mesh, that will set a deform key. When hiding an attachment the attachment is not keyed, the slot is:
Keys - Spine User Guide: Slot attachment

So, click the attachment visibility dot to hide/show the attachment you want to hide/show. If you have auto key on, a key is set for you automatically. If not, click the key button next to the slot (not next to the attachment). Most people leave auto key enabled.
Sure, here I made a video, so you can clearly see what I'm doing and give me advices

maranpis
  • Messaggi: 21

Nate

For some reason the video only shows a static image of the Spine UI. I hear the audio, but nothing changes in the video.

Selecting an attachment and pressing H for Visibility should be sufficient. For example, I open the spineboy example, create a new animation, click the mouth-grind attachment, press H, and I see a key was added in an attachment timeline (with auto key on):


I'm not sure why you'd not see this. Try creating a new animation so you don't have the clutter of other keys. If you are still having trouble, please post or email (contact@esotericsoftware.com) you project file and let us know how to reproduce the issue (eg which animation, what attachment do we select and press H).
Avatar utente
Nate

Nate
  • Messaggi: 12040

maranpis

Nate ha scritto:For some reason the video only shows a static image of the Spine UI. I hear the audio, but nothing changes in the video.

Selecting an attachment and pressing H for Visibility should be sufficient. For example, I open the spineboy example, create a new animation, click the mouth-grind attachment, press H, and I see a key was added in an attachment timeline (with auto key on):


I'm not sure why you'd not see this. Try creating a new animation so you don't have the clutter of other keys. If you are still having trouble, please post or email (contact@esotericsoftware.com) you project file and let us know how to reproduce the issue (eg which animation, what attachment do we select and press H).
Sorry I didn't notice here you have another video.

maranpis
  • Messaggi: 21

Nate

I don't think any deform key is being set. The deform key was there before you pressed H. Try experimenting with a new animation so you don't have other keys cluttering the dopesheet.

I see you have the dopesheet Sync button selected. That makes the dopesheet show only the rows shown in the graph. Probably if you open the graph view, you'll see that you have filters set that are preventing the attachment keys from being shown. Not being able to see the attachment keys you are setting could cause this confusion!
Avatar utente
Nate

Nate
  • Messaggi: 12040


Torna a Editor