catdsnny

I get endless reports of this error in the log window which basically makes debugging impossible. It only happens for SpineSkeletonRenderer components which have the X scale set to -1 (e.g. flipped).
catdsnny
  • Messaggi: 7

Mario

Do you have any other settings enabled on the SpineSkeletonRenderer component? Which spine-ue4 runtimes version are you using?
Avatar utente
Mario

Mario
  • Messaggi: 3242

catdsnny

I have many settings changed or enabled/disabled on the renderer component.

The issue only happens when I set a negative scale on the X for the renderer component.

Per this document:
spine-ue4 Runtime Documentation
The nodes "setflipx" and "setflipy" do not exist

I downloaded the zip file in mid January. It was after the most recent commit in the UE4 github subdirectory. The plugin reports version 1.0 although appears to have never been updated.

There is an issue in the UE4 c++ code which needs to be addressed. If the X or Y scale is negative this variable should be set. There is no penalty to setting it, so it just should be always set whenever the procedural mesh is regenerated.
https://docs.unrealengine.com/4.27/en-US/API/Runtime/Engine/PhysicsEngine/UBodySetup/bGenerateMirroredCollision/
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
catdsnny
  • Messaggi: 7

Mario

Thank you for the additional information. I just saw you already filed an issue on the tracker. Sorry for the incorrect documentation. The setFlipX/Y nodes were replaced with setScaleX/Y, where a positive number means not flipped, and a negative number means flipped. I'll try to get to the issue this week and will also fix up the documentation.

Just to make sure, you haven't attached a separate physics body to the actor, but have enabled collision mesh generation for the skeleton component, correct?
Avatar utente
Mario

Mario
  • Messaggi: 3242

catdsnny

No physics body attached (actor hierarchy below).

but have enabled collision mesh generation for the skeleton component,

There is a setting in the renderer component called "create collision" - that checkbox was set, although I did not set it as my project does not use collision. I did uncheck it and the messages still appear.

Also, I do not have physics enabled on the skeleton and the collision is set to "no collision".

Thanks!
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
catdsnny
  • Messaggi: 7

Mario

Thanks, I'll be updating this issue when it's fixed:
https://github.com/EsotericSoftware/spine-runtimes/issues/2032
Avatar utente
Mario

Mario
  • Messaggi: 3242


Torna a Runtimes