justifun

I guess i didn't properly submit my post, anywhoo, i think i came across a bug.

When scaling the spine with "bone compensate" toggle on, in the view port it scales only that bone and not the children ones, however if you set keyframes for that scale, and scrub the time slider, every bone scales. (1.0.8) havent tried 1.0.9 yet.
justifun
  • Messaggi: 44

Søren

This is not a bug. The child bones are compensating for the scale of their parents so you have to key them. An easy way to do this is to just press "K" after you have scaled the bone, this will key all bones that have been changed.

We have a stretch goal planned so you can disable scaling inheritance. If it's just a single bone you need to do scaling on, another way to do it is to place another bone (a "null" or zero length bone) on the one you want to scale. Then move the images from the bone you want to scale to the new one and scale that instead, then it won't have any children. It results in another bone, but fewer keys.
In this screenshot I am doing exactly that to squash the torso without affecting the head and hands


Hope it helps
Avatar utente
Søren

Shiu
  • Messaggi: 2452

justifun

Great, thanks for the help.
justifun
  • Messaggi: 44

justifun

So i've been playing around with this workflow and its becoming rather troublesome. Basically i need to add a second scaling only bone to every bone in my character just to be able to scale them thus doubling the amount of bones i need to keep track of. There's gotta be an easier way :(
justifun
  • Messaggi: 44

Nate

There's a feature pending to disable inheritance for scaling and rotation.
https://trello.com/card/bone-checkbox-t ... c0059d9/33
You can subscribe to that item to be notified of changes.
Avatar utente
Nate

Nate
  • Messaggi: 12133


Torna a Editor