Jan

Hi,

i backed this project on kickstarter, but i can't get the Spine.app to start/run. I have to use "Show package contents" from the context menu of the Spine.app and then brows to contents/Resources/Java/spine.jar and launch it.

spine.log (after runing the JAR-File):
Spine 1.0.9-trial
Mac OS X x86_64 10.8.2
NVIDIA Corporation
NVIDIA GeForce 9400M OpenGL Engine
2.1 NVIDIA-8.0.61
Java 1.6.0_37
Apple Inc.
Java HotSpot(TM) 64-Bit Server VM
Started.
Note:
1. Allow applications download from everywhere is selected in the System Preferences.
2. I have installed Little Snitch (latest release). But no Spine.app appear in the Rules. Only the JAR Launcher.

regards Jan
Avatar utente
Jan
  • Messaggi: 8

Søren

Hey Jan, we'll try to get that fixed ASAP, sorry for the inconvenience.
Avatar utente
Søren

Shiu
  • Messaggi: 2452

Nate

I'm afraid there are some issues running with Java 7 on the Mac. Can you try opening Java Preferences and checking Java 6 if possible?
Avatar utente
Nate

Nate
  • Messaggi: 12040

Jan

I can try this... but first i have to install the JAVA Preference Pane ... Apple removed this in an mountain lion update (i think it is the same update that pulled java support from the safari browser).

Edit:
here is a how to from apple
https://support.apple.com/kb/HT5559

regards Jan
Avatar utente
Jan
  • Messaggi: 8

ammarz

it worked for me out of the box, I bought it through this website, I have Java 7 runtime & sdk installed on osx 10.8.2
Avatar utente
ammarz
  • Messaggi: 7

Nate

Spine should now run correctly using Java 7 on Mac, as of Spine version 1.0.10. So many hours wasted fixing this, I hate you Apple!
Avatar utente
Nate

Nate
  • Messaggi: 12040

Jan

Hi,

tried the 1.0.11 Version... didn't worked for me.

Console.app Log-Messages:
16.02.13 00:04:25,087 com.apple.launchd.peruser.501[346]: ([0x0-0x140140].Spine[1710]) Job failed to exec(3) for weird reason: 13
16.02.13 00:04:25,089 Dock[365]: no information back from LS about running process
yeah... weird! ;)

regards Jan
Avatar utente
Jan
  • Messaggi: 8

Nate

Erhm, are you sure that is 1.0.11? :(
Avatar utente
Nate

Nate
  • Messaggi: 12040

Jan

Hi Nate,

found the damn little error...
localhost:~ nf$ cd /Applications/Spine.app/Contents/MacOS/
localhost:MacOS nf$ ls -la
total 5376
drwx------ 5 nf staff 170 16 Feb 11:14 .
drwx------ 6 nf staff 204 16 Feb 11:14 ..
-rw-r--r-- 1 nf staff 471 15 Feb 23:21 run.sh
-rw-r--r-- 1 nf staff 2655384 15 Feb 23:21 spine.jar
-rw-r--r-- 1 nf staff 89681 15 Feb 23:21 splash.png
fix:
cd /Applications/Spine.app/Contents/MacOS/
chmod +x run.sh
Spine starts now perfectly!

Hope this helps some others with similar problems on mac os x!

regards Jan
Avatar utente
Jan
  • Messaggi: 8

Nate

Great, thanks! What kills me is why the executable flag is lost for some users but not all... :'( Also what is strange is you should have gotten a different error if it were a permissions issue:
2/16/13 1:04:23.792 PM com.apple.launchd.peruser.501: ([0x0-0x290290].Spine[4867]) posix_spawn("/Users/nate/Desktop/spine-1.0.12trial-mac/Spine.app/Contents/MacOS/run.sh", ...): Permission denied
2/16/13 1:04:23.793 PM com.apple.launchd.peruser.501: ([0x0-0x290290].Spine[4867]) Exited with code: 1
Avatar utente
Nate

Nate
  • Messaggi: 12040

Jan

maybe it's because of different extraction tools.

i used Keka ( http://www.kekaosx.com/en/ )

just a guess ;)
Avatar utente
Jan
  • Messaggi: 8

Nate

I will give that a try. Why don't people just use the built-in extraction... you're using a Mac after all...
Avatar utente
Nate

Nate
  • Messaggi: 12040

Jan

the built in doesn't support that many file-formats and is not capable of handling damaged archives ;)

btw.: Another thing i noticed is that the icon in the dock is not the same as the Spine.app, it's the typical JAR-File Icon - is that normal... would love to see the spine icon in the dock ;) ?

regards Jan
Avatar utente
Jan
  • Messaggi: 8


Torna a Editor