Nick

I am dynamically creating SkeletonGraphic GameObject from script. When using SkeletonAnimation, there is a tintBlack field for us to enable TintBlack but I don't see such field under SkeletonGraphic.
Nick
  • Messaggi: 310

Mario

You need tomuse the Spine/SkeletonGraphic TintBlack or Spine/SkeletonGraphic TintBlack CanvasGroup shaders to enable tint black on a SkeletonGraphic. See spine-unity Runtime Documentation: SkeletonGraphic Component
Avatar utente
Mario

Mario
  • Messaggi: 3157

Nick

Thanks, I know I need to use tint black shader.

Unity_qxoZtPPyRs.png


The problem is I don't know how to toggle the bool to make it use Tint Black. The visual is incorrect until I toggle the setting from the inspector under the advance section but I am seek way to do it by script. There is no tintBlack field under SkeletonGraphic class for me to enable it.
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
Nick
  • Messaggi: 310

Harald

It is indeed not as comfortably exposed at the SkeletonGraphic component API. To set it via code you need to use skeletonGraphic.MeshGenerator.settings.tintBlack = true;.
Avatar utente
Harald

Harri
  • Messaggi: 4208

Nick

Thanks
Nick
  • Messaggi: 310


Torna a Unity