romontwilly

Good morning, I have a problem that I can't solve, I have a problem opening Spine 4.0.53, it automatically closes.

in Spine.log this message appears:

Spine Launcher 4.1.02
Esoteric Software LLC (C) 2013-2021 | http://esotericsoftware.com
Mac OS X x86_64 10.15.7
Intel Inc., Intel HD Graphics 4000 OpenGL Engine, 2.1 INTEL-14.7.20
Starting: Spine 4.0.53 Professional
Spine 4.0.53 Professional
Licensed to: *****, *****
ERROR: Error reading hotkeys file: /Users/pro/Library/Application Support/Spine/settings/hotkeys-1.txt
Invalid action: New Physics Constraint
Invalid action: Physics Constraint - Edit Physics
Invalid action: Edit Physics - Modify
Invalid action: Edit Physics - Create
Invalid action: Edit Physics - Delete
Started.
OpenAL 1.1, Default audio device
romontwilly
  • Messaggi: 3

Mario

Could you try deleting that file and restart Spine (make a backup of the file first)? What version of Spine did youmuse previously?
Avatar utente
Mario

Mario
  • Messaggi: 3154

romontwilly

It was working perfectly a few weeks ago, but now it doesn't. The only version that opens is Spine 3.8.
I've erased the software, installed it again, restarted it, but it still doesn't work.
romontwilly
  • Messaggi: 3

Nate

When you say it doesn't work, I guess you mean the Spine launcher window appears, you choose eg Latest 4.0, the launcher disappears, and then the Spine editor window never appears?

From the log it looks like everything is working. The hotkeys file error in the log is just because you've run 4.1-beta. It won't affect the Spine window showing.

Do you have multiple monitors? Could you try running Spine with just one monitor? If you have a laptop, try without any monitors, just the laptop screen.

Have you installed any new software recently? Anything related to monitors, screen sharing, or similar?
Avatar utente
Nate

Nate
  • Messaggi: 12024

romontwilly

I've attached some pictures to explain it better.
I only use a Wacom Cintiq. But I tested it with it on and off when I switch to version 3.8. It works fine, but in version 4.0 or later it doesn't.

---

I use a Macbook Pro (13-inch, Mid 2012).
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
romontwilly
  • Messaggi: 3

Mario

Please post the full crash log from the dialog in your second image. I assume you have recently updated your macOS version. Some users with Intel GPUs have reported issues with the October update of macOS due to a bug in the Intel GPU driver. You are running the latest Catalina update released today. It appears that still has this bug, or a new bug.
Avatar utente
Mario

Mario
  • Messaggi: 3154


Torna a Bugs