Jamez0r

Hey guys, been having this bug for at least the past 6 months, and finally narrowed it down and recorded a video of it.

It happens when you duplicate an Event (I use ctrl+D), and subsequently rename it.

Here is a video of it, starting with creating a "New Project" in Spine. Note that I had to attempt recreating the bug several times (doing slightly different things) to get it to happen - so I'm not sure if seemingly unrelated things (like creating an empty Event folder, or switching from Setup to Animate and then back to Setup) are required for the bug to happen or not.



And just so its clear, in the video, I selected "Test 1" and then pressed ctrl+D to duplicate it, which created "Test 4". I then selected "Test 4" and pressed F2 to rename it, and renamed it to "RenamedTest 4" -> when I did this, "Test 1" also was renamed to "RenamedTest 4".

Sorry that video is slow, it was like my 10th attempt at recreating the bug :lol:
Avatar utente
Jamez0r
  • Messaggi: 358

Erika

Hello, thanks for the repro video! It really helped figuring out what the steps actually were. I was able to narrow down the cause!

It can be reproduced on any example project too.
Steps:
1. Open a project and switch to Animate mode
2. Select the Events node in the tree, choose New>Event and call the new event test1
3. Select test1 and press Ctrl+D (nothing happens)
4. Go back to Setup mode and press Ctrl+D (a copy is made)
5. Rename the copy and also the original event is renamed.

Note: if the lines in bold are not performed, the bug does not happen, so the key is to try to duplicate while in Animate mode.

On Spineboy all it takes is:
1. Open the Spineboy project and switch to Animate mode
2. Select the footstep event and press Ctrl+D (nothing happens)
3. Go back to Setup mode and press Ctrl+D (a copy is made)
4. Rename the copy and also the original event is renamed.

I've opened an issue to track it:
https://github.com/EsotericSoftware/spine-editor/issues/623
Avatar utente
Erika

Erikari
  • Messaggi: 3098

Jamez0r

Thanks Erika!
3. Select test1 and press Ctrl+D (nothing happens)
Oh geez, guess I might have done that, but you guys couldn't see it in the video obviously. Nice job figuring that out :detective: :detective:

Also :lol: I guess that means I've been trying to duplicate Events in Animate mode a lot, since I've run into this issue probably 5 or 6 times lol
Avatar utente
Jamez0r
  • Messaggi: 358


Torna a Bugs