keithmaxx

My animation staff tells me that upon upgrading to the latest trial version 1.8.10, the application does not start at all.

Up until last week's update, the software ran fine. As it was updated, the Loading indicator stopped at 99% and become unresponsive after that. There was then no other choice but to uninstall and then install the latest exe available for download at the time.

Attempting to start up the application displays the icon on the taskbar, but not much else; the program wouldn't start. Please refer to the JPG file attachment for reference.
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
keithmaxx
  • Messaggi: 5

Søren

Hmm very strange.Could you try deleting or renaming the \Users\<name>\Spine folder to something else and see if you can start it then please?
Avatar utente
Søren

Shiu
  • Messaggi: 2453

keithmaxx

Thank you for your response.

Unfortunately, even after trying to rename the folder the application still fails to launch.
keithmaxx
  • Messaggi: 5

Nate

If you need to go back to an older version of Spine for now, you can edit this file:
Windows: <user home folder>\Spine\version.txt
Mac: <user home folder>/Library/Application Support/Spine/version.txt
Linux: <user home folder>/.spine/version.txt
In that file type a version ("1.7.12" is the oldest you can go, you may also try "1.8.09", don't type the quotes), save, then when you start Spine it will load that version. Editing the version.txt file is the same as choosing a version in the Spine settings dialog, but of course if Spine won't start then you need to edit the file.

It would help if you can report if 1.7.12 or 1.8.09 works, as this will tell us if there is a problem in the launcher or in a specific update version.
Avatar utente
Nate

Nate
  • Messaggi: 12210

keithmaxx

Apparently, installing to a previous Essential version (like 1.7.12) indeed prompts us to "revert" to an old version, and we only have the 1.7.12 version as a choice.

Now despite changing the aforementioned version.txt content to 1.8.09, the same Revert prompt appears and resets the txt file content back to 1.7.12 each and every time. Are there other suggestions?
keithmaxx
  • Messaggi: 5

Nate

Sorry, I'm not clear on which launcher you are using. I'll explain in more detail.

When using the new launcher, you can choose any update from 1.7.12 and above.

When using the old launcher, you can only choose from updates you have downloaded previously, or the latest. Since the latest at this time is 1.8.13 and anything above 1.8.00 is incompatible with the old launcher, using the latest will get you the "launcher update required" prompt.

That the old launcher is so limited to what update can be chosen is a big problem. This is why we put other very important things on hold (skinning, updating the runtimes for FFD, etc) and updated the launcher now. I wish it could have been done in a way that was compatible with the older versions, but its actually extremely complicated. There are many edge cases for updates and its quite fragile, if something in the launcher goes wrong then people can't use Spine at all, and that is bad. It took weeks to get the new launcher working.

At any rate, if you would like to use 1.7.12 then its easiest to use the new launcher and put 1.7.12 in the version.txt. I would like to fix the problem you are having though. Maybe we could chat on IRC or Skype and work through it? Maybe we could do Team Viewer or JoinMe and I could investigate directly on a machine with the problem. Currently it's very difficult for me to debug since I can't see it fail.
Avatar utente
Nate

Nate
  • Messaggi: 12210


Torna a Bugs